Hallo und Herzlich Willkommen im RC-DROHNEN-FORUM.
Wir sind ein unabhängiges, rein privat geführtes Forum zum Thema Multicopter (Drohnen) speziell für Luftbild-Aufnahmen und Technik für den privaten- und gewerbliche Piloten.
Ein lockerer, freundlicher Umgang gepaart mit Know-How, Hilfsbereitschaft und ein respektvolles Miteinander erwarten Dich hier.
Melde Dich kostenlos an, um alle Funktionen nutzen zu können. Wir freuen uns auf Dich!
Viel Spaß wünscht Dir das RCDF-Team.

Offizieller Partner des BVCP - Bundesverband Copter Piloten

Ungewolltes Update?

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Ungewolltes Update?

      Hallo,

      Nachdem ich eine Weile ausser Gefecht war, das liebe Kreuz mit dem Kreuz, habe ich heute nach einer längeren Zeit wieder den H520 in Betrieb genommen.
      Nach dem Start der St16s habe ich erstmal Datum und Uhrzeit kontrolliert, alles ok. Dann habe ich warum auch immer den Update Pilot gestartet und siehe da
      ein Update war verfügbar. Von Yuneec war eigentlich von einem Update nicht die Rede. Habe es dann durchlaufen lassen zusammen mit der E90.
      Ergebnis war:
      UpdatePilot 1.6.1.0
      RemoteControl TX 0.39.0
      System 1.0.11
      DataPilot 1.6.92.0
      Camera 1.0.80A
      FlightControl 1.7.116
      Gimbal 2.66.1 siehe auch Bilder

      Habe dann alles gecheckt einschliesslich eines Neustarts des Systems. Das erste was mir aufgefallen ist, obwohl im Android Menü Deutsch eingestellt ist erfolgt die Sprachausgabe im DataPilot nur in Englisch. Ok, nicht das grosse Problem. Habe dann vorsichtig einen Probeflug gemacht. Das nächste was auffliel war die langsame Steiggeschwindigkeit bis glaube ich 20m, dann klappten automatisch die Landebeine ein und die Steiggeschwindigkeit war wieder normal.
      Ansonsten im Flug alles normal. Das Zoomen der Kamera erfolgt etwas fliessender. Beim Check der Missionsplanung fiel mir aber sofort auf das die Funktion POI
      fehlt. Das würde mich schon sehr ärgern da ich gern mit dieser Funktion operiert habe.Aus Zeitgründen habe ich nicht weiter geforscht und erstmal abgebrochen.
      Hat jemand vielleicht eine Idee was mit es mit diesem Update auf sich hat. Oder habe ich während meiner Krankheit etwas wichtiges verpasst?

      LG BOS Man
      Dateien
      • image0.jpeg

        (1,39 MB, 5 mal heruntergeladen, zuletzt: )
      • image2.jpeg

        (690,64 kB, 5 mal heruntergeladen, zuletzt: )
      • image3.jpeg

        (664,85 kB, 7 mal heruntergeladen, zuletzt: )
      • image4.jpeg

        (763,81 kB, 6 mal heruntergeladen, zuletzt: )
    • BOS-Man schrieb:

      Ergebnis war:
      UpdatePilot 1.6.1.0
      RemoteControl TX 0.39.0
      System 1.0.11
      DataPilot 1.6.92.0
      Camera 1.0.80A
      FlightControl 1.7.116
      Gimbal 2.66.1 siehe auch Bilder

      Merkwürdig,

      tatsächlich sind alle Versionsnummern neu. Gibt es evtl. nur per online update (OTA) durchUpdatePilot. Auf der Yuneec-Site und auf den einschlägigen Download-Seiten ist auch noch alles beim Alten...

      Wenn es Probleme gibt, warte ich lieber erst einmal. Vielleicht ist es ja schon mal ein Vorbote der C2-Klasse per Software (z.B. Langsamflugmodus bei ausgefahrenem Fahrwerk?).
      Die C2-Logos sind jedenfalls "schon" auf der Website eingebaut...
      Schlimmstenfalls waren die Files für den H520E gedacht lol (O.K., glaube ich nicht wirklich)
    • Das hier und da schon Kassifizierungslogos auftauchen finde ich echt cool
      So wie ich das mit bekommen habe soll es ja eigentlich ein eindeutiges Layout geben
      Zertifiziert und Eingetragen sollte es sein
      Von Betriebserlaubnis freigaben habe ich auch noch nichts gehört
      Aber egal
      Man kann ja schon mal mit werben
      Mal mit bunten farben Mal das C in rot mal in schwarz weis
      Na ja so ein C könnte auch alles andere bedeuten
    • BOS-Man schrieb:

      habe in KK angerufen. Neues Update ist ok,
      nur noch nicht publiziert.

      Hallo,
      zum Thema C2-Zertifizierung für H520 hat ein "Drohnen-Kollege" :thumbup: heute folgende Antwort aus KK bekommen:

      "Wir arbeiten zurzeit an der Zertifizierung. Leider sind hier die Vorgaben der EU noch nicht fertig.
      Wir müssen Sie daher um etwas Geduld bitten."

      Also: Die nachträgliche C2-Zertifizierung ist in Arbeit. grumble Das heißt aus der Bestands-Drohne wird ein EU 2019/945-Copter! Ärgerliche

      :thumbsup:
      [/quote]
    • BOS-Man schrieb:

      Ja, ist schon merkwürdig. Vielleicht wissen andere Piloten noch was.
      Hallo,
      habe heute mal die neuen FWs geflogen und es gab bei mir ernste Probleme im Flug (Angle-Mode). Evtl. lag es an den Outdoor-Kalibrierungen (Compass, Accelerometer und neu: Gyroscope) bei Temperaturen von ca. +1 °C heute.
      Ich habe in einem US-Forum eben etwas geposted. Hier davon die Google-Translator-Übersetzung:

      Hallo,dasselbe hier. Habe heute neue FWs mit H520 und E90 getestet. Zuerst kam die Nachricht "Compas # 0 nicht kalibriert". Nach erfolgreicher Kalibrierung der nunmehr drei Sensoren (Kompass, Beschleunigungsmesser und neu: Gyroskop) führte der erste Flug mit Start im "Angle-Mode" dazu, dass sich der H520 von selbst zu mir drehte und auch einige unbeabsichtigte Schräglagen machte. Ich wechselte in den "Manuellen Modus" und bekam den Vogel wieder unter Kontrolle und landete ihn.

      Der zweite Flug (Warmstart) war in Ordnung. Nach dem Neustart/Reboot der Drohne und der FB (Kaltstart mit allen Sensoren, die alle grün anzeigten) traten die Probleme im "Angel-Modus" erneut auf und die Drohne drehte/kippte sich und driftete von selbst auf einen Baum zu. Ich musste wieder ziemlich schnell reagieren: Der H520 geriet definitiv "außer Kontrolle" und driftete ab, während er offensichtlich fehlerhaften Kompass- / GPS-Signalbedingungen folgte. (Es gab keinen bis wenig Wind, "Weltraumwetter" war K1, Temperatur+ 1 ° C)

      Ich habe es ein drittes Mal versucht und das Problem trat erneut auf. Ich bemerkte auch einige Steig-/Sink-Anomalien (die etwas entgegengesetzt zu meinen Schub-Eingaben reagierten), als ob jetzt ein Problem mit nicht übereinstimmender Druck- und GPS-Höhe (vertikale POS-Drift?) bestehen würde.

      Draußen war es etwas kalt, aber über der minimalen Betriebstemperatur. Möglicherweise verursachte das Kalibrieren bei kaltem Wetter diese Probleme im Flug. Trotzdem treten die "neuen" Warnungen "GPS-Vertikal-Drift-zu-hoch" und "GPS-Horizontal-Drift-zu-hoch" auch bei Raumtemperatur nach Kalibrierung in Innenräumen bei etwa + 22 ° C auf. Hier sind einige Screenshots von heute:


      Screenshot_2021-01-16-12-54-06-edit.jpgScreenshot_2021-01-16-00-13-39-GPS-vertical-drift-too-high.jpgScreenshot_2021-01-16-00-13-39-GPS-horizontal-drift-too-high.jpgScreenshot_2021-01-16-00-13-39-GPS-compass#0-uncalibrated.jpg

      EDIT: enige Korrekturen in der Google-Übersetzung ;)

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von vr-pilot ()

    • Guten Morgen vr-pilot.

      Danke für die Information.

      Ja , auchich bekomme die Meldung. Das zu Hause im trockenen ohne zufliegen.


      Es gib auch noch auf der ST16S neue Einstellungen.


      1. Aktivieren Sie die Unterstützung für PLRS. die AUX-Taste, um die Nutzlast freizugeben.

      2. Aktivieren Sie diese Option, wenn Sie einen Stoßfängerkäfig angebrachthaben. Das Fahrwerk ist dann deaktiviert.


      Könnte es mit den Einstellungen (1.) noch zu tun haben?

      Ich werde mal in KK nachfragen, ansonsten versuche ich das ganze wieder zu Downgraden.


      happy Landing

      Airmor
      Dateien
      • Einstellungen.jpg

        (109,79 kB, 3 mal heruntergeladen, zuletzt: )
      • Preflight.jpg

        (412,2 kB, 4 mal heruntergeladen, zuletzt: )

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Airmor () aus folgendem Grund: Formatierung

    • Neu

      Airmor schrieb:

      Könnte es mit den Einstellungen (1.) noch zu tun haben?

      Ich werde mal in KK nachfragen, ansonsten versuche ich das ganze wieder zu Downgraden.
      Hallo Airmor,

      "Software is a bitch", das kennt jeder, der schon mal irgendetwas programmiert hat. Schon bei geringer Komplexität entwickelt sich schnell ein Eigenleben, das schnell übersehen werden kann.
      Deshalb ist es richtig nichts dergleichen auszuschließen, nur weil es auf den ersten Blick nichts damit zu tun haben dürfte...

      In dem US-Forum wird jedoch eher vermutet, dass die teilweise auftretenden Gimbal- und GPS-Probleme mit der neuen Gyroscope-Kalibrierung "dazugekomen" sind.

      Ich habe bei meinem "GPS-Flug Richtung Baum" vorgestern (den ich im Manual Mode sicher beenden konnte) in der 3D-Flugdarstellung der PX4-Daten gestern folgendes festgestellt:
      Beim Abheben im Angle Mode (GPS) stand der Kompass auf 060°und nach der Landung im Manual Mode (Position und Ausrichtung wie beim Start) auf 135°. Richtig bei meinem Test-Startplatz sind 135°.

      Beim Betrachten der 3D-Flugdarstellung kann man während der "Baumannäherung" kurz nach dem Start im GPS-Mode sehen, wie der Kopter beginnt sich selbständig um die Hochachse zu drehen (und zur Seite zu fliegen). Somit fand im Flug eine selbständige Anpassung an sich "verändernde" Kompassdaten statt, die dann bei der Landung den korrekten Wert hatten.

      Es gab keine hörbare Warnung. Ob auf dem Display eine Warnung stand, kann ich nicht sagen, weil ich in dem Moment meinen Kopter davon abhalten musste weiter in Richtung Baum zu "driften".


      Falls das Wetter es morgen zulässt, werde ich weitere Tests fliegen. Zumindest Indoor zeigt der Kompass heute "zuverlässige" Werte an. Vielleicht war es vorgestern einfach zu kalt beim Kalibrieren bzw. dann die Wartezeit bis zum Erstflug in der "Kälte " (+1°C) zu lang. Oder es liegt doch an der neuen Gyroscope-Kalibrierung.


      Von meinem "Drohnen-Kollegen" aus Thread Nr. 6 habe ich gehört, dass er gar nichts kalibriert hat und der Kopter sehr gut geflogen ist...
    • Neu

      Guten Abend vr-pilot,

      Ich habe mit KK kontakt gehabt und dieses Problem geschildert.
      War wie immer, ein kompetentes und nettes Gespräch!!

      Sie haben mit der Firmware bei ihren Flügen keine solche Meldung bekommen.

      vr-pilot schrieb:

      Oder es liegt doch an der neuen Gyroscope-Kalibrierung.

      Wir haben auch über diese Gyroscope-Kalibrierung gesprochen. Sie werden es sich Anschauen.

      Deshalb warte ich noch mit den Downgrades ab.

      Ich bin Überzeugt, dass sich etwas ergeben wird.

      Bei mir ist es momentan zu Kalt, wegen den Fingern, zum Testfliegen.


      Happy Landing beim Testflug

      LG
      Airmor
    • Neu

      Airmor schrieb:

      Ich habe mit KK kontakt gehabt und dieses Problem geschildert.
      War wie immer, ein kompetentes und nettes Gespräch!!

      Sie haben mit der Firmware bei ihren Flügen keine solche Meldung bekommen.
      Hallo Aimor,

      danke für die Info. Es gibt ja seit dem Update-Paket so einige Meldungen bei den Anwendern, hier meine aktuelle "Sammlung":
      "primary gyroscope not found", "Compass #0 uncalibrated", "GPS horizontal drift too high", "GPS vertical drift too high", "GPS speed accuracy too low"

      Dass nun wiederum KK bei ihren Flügen gar "keine solche Meldung bekommt" wundert mich allerdings.
      Aber es stimmt schon: Der Service bzw. die persönliche Ansprache seitens KK ist immer sehr positiv.


      Auch dass es möglich scheint nach Aufspielen des Update-Pakets ohne irgendeine Kalibrierung fehlermeldungsfreie Flüge durchführen zu können wundert mich eher...
    • Neu

      vr-pilot schrieb:

      Hallo Aimor,
      danke für die Info. Es gibt ja seit dem Update-Paket so einige Meldungen bei den Anwendern, hier meine aktuelle "Sammlung":
      "primary gyroscope not found", "Compass #0 uncalibrated", "GPS horizontal drift too high", "GPS vertical drift too high", "GPS speed accuracy too low"

      Das sind "typische" PX4 Fehlermeldungen, also nicht unbedingt Yuneec abhängig.

      Beim kalibrieren des Gyros ist mir aufgefallen das der H520 wirklich absolut still stehen muss. Einfach ruhig mit der Hand festhalten reicht nicht.
      Ich habe den H520 dann seitlich an eine Wand gelehnt, dann lief die Kalibrierung sauber durch.
      Also, eine saubere Kalibrierung nach dem Update ist wirklich Pflicht. Ich habe hier die Vermutung das die wenigsten den Gyro korrekt kalibrieren! :(

      Gruß
      Uli
    • Neu

      Ulrich_W schrieb:

      Ich habe den H520 dann seitlich an eine Wand gelehnt, dann lief die Kalibrierung sauber durch.
      Hallo Uli,

      sehr gut, dass Du das ansprichst! Genau das ist mir ein Rätsel. Ich habe mich gefragt, wie denn genau die Gyroscope-Kalibrierung ablaufen soll.
      Der PX4-Text lautet "For Gyroscope calibration you will need to place your vehicle on a surface and leave it still. Click Ok to start calibration."
      Das Copter-Symbol ähnelt hierbei den Darstellungen aus der Compass/Accelerometer-Kalibrierung. Die Abbildung ist für mich eine Mischung aus Kompass-Rotations-Achsen und Accelerometer-Boden-Aufstellung.
      Du sagst nun, Du würdest für die Gyroscope-Kalibrierung den H520 an die Wand lehnen, sicherlich so dass es der Copter-Symboldarstellung enstpricht.
      Das würde mir nicht in den Sinn kommen, weil das Gyroscope als Lagesenor zur Kalibrierung doch "lotrecht zum Erdmittelpunkt" ausgerichtet sein müsste.(?) Eine Ruhemessung in 90° Seitenlage links und dabei 30° "nach rechts" gedreht halte ich - auch auf Grund der Praktikabilität (absolute Ruhelage) - für eher unwahrscheinlich. Aber evtl. liege ich hier ja genau falsch.
      Durchaus denkbar, dass erst durch diese besondere Position die drei Achsen deutlicher/trennbarer ausgelesen werden können. Wenn die Software-Kalibrierung dann weiß, dass der Copter gerade senkrecht an der Wand lehnt und dabei auf den Motorarmen seite-links und hinten-links ruht könnte es etwas werden... ;)
      Was mich allerdings wiederum skeptisch macht ist, dass es sich hierbei lediglich um eine 30°/60°-Abwandlung aus den Accelerometer-Positionen handelt.
      Ich hatte den Copter zu Gyroscope-Kalibrierung auf eine "absolut" ebene Fläche gestellt, was dann natürlich "granatenfalsch" wäre lol

      Umso erstaunlicher, dass er dann überhaupt noch (ohne GPS) ganz anständig geflogen ist.
      Im Moment regnet es "wie Sau" Urlaub3 aber sobald möglich werde ich mal einen Testflug mit Seitenlagen-Kalibrierung machen.

      Screenshot_2021-01-16-13-24-27.pngScreenshot_2021-01-16-14-20-46.pngScreenshot_2021-01-16-14-21-08.png

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von vr-pilot ()

    • Neu

      Möööp...so, zur Sicherheit habe ich schnell bei Yuneec angerufen.

      Ich habe das Bild FALSCH interpretiert! Yuneec sagt das der H520 auf einer ebenen Fläche stehen muss für die Gyro Kalibrierung!

      Ich bin aber davon noch nicht so überzeugt...werde beides mal testen, sobald es hier mal aufhört zu regnen ||
      Mir ist nicht so klar wozu dann explizit die Achse und die beiden grünen LED (?) angezeigt werden?

      Gruß
      Uli
    • Neu

      Hai Leute,

      ich habe soeben auch die neuen Updates wie BOS-Man schrieb heruntergeladen. Bis auf eines lief das auch ganz gut. Das Update für die Kamera nennt sich bei mir 1.0.80_E, warum kein A dahinter steht kann ich nicht sagen. Vielleicht kann da jemand von Euch weiterhelfen.

      Des Weiteren hatte ich nach dem Update das Problem das sich die St16s nicht mehr mit der Kamera verbindet. Danach setzte ich die Kamere über den Reset-knopf zurück. Auch kam hier keine Verbindung mit der Kamera zustande. Ich beschloß die Speicherkarte aus der Kamera zu nehmen und hatte noch einiger Zeit eine Verbindung zur Kamera. Bei der Speicherkarte handelt es sich um durch Yuneec empfohlene Speicherkarte mit 64 GB. Als ich im Anschluss die Speicherkarte formatierte war das Problem beseitigt.

      Ach so, den Gyro konnte ich kalibrieren, dass war kein Problem.

      Leider kann ich hier aufgrund er Witterungsverhältnisse nicht aufsteigen. Mal schauen wie es morgen wird. Ich werde berichten.

      Gruß Sven
    • Neu

      Ulrich_W schrieb:

      Tja, was soll ich sagen....Testflug mit einem nach "meiner Methode" kalibrierten Gyro war absolut OK. Keine einzige Fehlermeldung. Und nu?
      Gute Frage. Schon merkwürdig, dass der Copter mit derart unterschiedlich ausgeführten Gyroscope-Kalibrierungen "klar kommt".
      Eigentlich müsste es für eine falsch ausgeführte Gyroscope-Kalibrierung auch einen Hinweis geben wie: "Kalibrieung nicht möglich: bitte Copter auf geraden Unterboden stellen" bzw. "bitte wie abgebildet auf der Seite stehend positionieren."
      Nach meiner "gerader Unterboden"-Methode hatte ich ja arge GPS-Drifts durch "wandernde" Kompasswerte. Ich war heute nicht mehr fliegen, mir war es einfach zu nass...
      Deshalb noch einmal vielen Dank für den selbstlosen Einsatz von "Mensch und Maschine" im Regen :thumbup:
      Morgen fliege ich - wenn es mal nicht Bindfäden regnet - mit Kalibrierungen, die bei Indoor-Temperaturen durchgeführt wurden. In meinem Fall habe ich auch die langen Kalibrierungsvorgänge draußen bei +1°C im Verdacht, Windchill -4 °C.